GRE туннели между маршрутизаторами Cisco

Опишем простую настройку GRE-туннеля между двумя маршрутизаторами Cisco.

За основу возьмем INEшную топологию и настроим туннель между двумя маршрутизатора, чтобы не забыть, как это делается. Настройка крайне просто и займет совсем немного времени, просто нужно помнить определенные моменты.

ine_gre

Настраиваем туннель между маршрутизаторами R1 и R10. В итоге мы должны добиться того, чтобы была взаимная доступность сетей 192.168.40.0 и 172.16.0.0.

R1:

interface Tunnel0
 ip address 10.0.1.1 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 169.254.54.2
 
ip route 192.168.40.0 255.255.255.0 Tunnel0

R10:

interface Tunnel0
 ip address 10.0.1.2 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 169.254.54.1
 
ip route 172.16.0.0 255.255.255.0 Tunnel0

Как видно, настройка крайне проста и тривиальна. Мы создали туннельный интерфейс, назначили ему ip-адрес, привязали его в внешнему интерфейсу маршрутизатора и указываем маршрут на внутреннюю подсеть соседнего маршрутизатора через наш туннельный интерфейс.

 

Настройка IP SLA на Cisco

Про IP SLA, да как, в общем-то, и про все те вещи, о которых написано в моем блоге, можно найти кучу статей с разбором о том, что для чего надо и как это настраивается. Я же, в свою очередь, внесу свою лепту и добавлю в эту большую кучу ещё и частичку от себя.

В данной статье будет рассмотрен классический вариант применения IP SLA — та схема, в которой есть два провайдера, трафик по умолчанию идет на основного, а при падении его автоматически перенаправляется на резервного. В общем, ничего нового 😉 Поехали.

IP SLA

Continue reading Настройка IP SLA на Cisco

Policy-based Routing

В данной статье будет рассматриваться настройка Policy-based Routing (далее PBR). PBR нужен для того, чтобы маршрутизировать трафик на основе каких-то политик, которые изначально задаются администратором. Например, можно направить трафик, который пришел с определенного IP и на определенный порт на какой-то IP адрес, например, на прокси.

Ниже мы рассмотрим работу и настройку PBR на практике.

PBR

Continue reading Policy-based Routing

Настройка RSTP

Привет, коллеги. В рамках длительной подготовки к сертификации CCIE R&S будут выкладываться лабораторные работы, которые позволят освежить в памяти различные тонкие моменты в настройке протоколов.

Первая из них позволит освежить в памяти протокол STP и некоторые моменты в его настройке. Лабораторные выполняются мною в UnetLab.

Итак, начнем. У нас есть задание и чтобы выполнить его, нам надо построить в UnetLab следующую топологию:

Switches Topology

Continue reading Настройка RSTP

OSPF reliable conditional default routing

Сегодня рассмотрим ситуацию, когда необходимо отдавать маршрут по умолчанию в какую-то зону, при этом отталкиваясь от каких-то условий.
Например, анонсировать маршрут только тогда, когда какой-то адрес в сети доступен.

Итак, у нас есть задача:

Настройте R5 так, чтобы маршрут по-умолчанию передавался в OSPF домен только в том случае, если достоверно известно, 
что есть связность между адресами 155.1.54.4 и 155.1.54.5

Continue reading OSPF reliable conditional default routing