Reflexive ACL

Reflexive ACL  динамически открывает входящее соединение при срабатывании записи в OUTBOUND ACL.

Пример ниже создает зеркальный ACL MIRROR, который позволяет пропускать обратный трафик.

ip  access-list extended OUTBOUND
 permit tcp any any reflect MIRROR
 permit  udp any any reflect MIRROR
 permit icmp any any reflect MIRROR
 !
 ip access-list extended INBOUND
 evaluate MIRROR
 !
Применяем ACL на интерфейсе:
interface Ethernet0/0
 ip address 1.1.1.1 255.255.255.0
 ip access-group INBOUND in
 ip access-group OUTBOUND out

BGP Local-as/no-prepend replace-as

BGP Local-asПараметр no-prepend replace-as дает возможность скрыть реальную AS при BGP-соседстве. Заменяется она на ту, которая прописана в команде local-as. Без no-prepend replace-as наша реальная AS будет присутствовать в AS-path наряду с указанной в команде local-as. Continue reading BGP Local-as/no-prepend replace-as

Суммаризация маршрутов. Напоминание

Для EIGRP или RIP:

interface e0/0 (интерфейс, за которым находятся соседи)
  ip summary-address [eigrp AS NUMBER |rip]  0.0.0.0/0

Для OSPF.

На ABR:

 router ospf 1
  area # range 0.0.0.0 0.0.0.0

На ASBR: (суммирование маршрутов из других AS)

 router ospf 1
  summary-address 192.0.0.0/16

Для BGP:

router bgp 1
  aggregate-address 0.0.0.0 0.0.0.0 summary-only
либо
router bgp 1
  neighbor x.x.x.x default-originate

либо
router bgp 1
  default-information originate

OSPF filter-list — напоминание.

Virtual Link

Если мы не хотим анонсировать LSA из AREA 1 в AREA 2, то на ABR роутере (R3) надо добавить:

area 1 filter-list prefix NoArea_1 out

ip prefix-list NoArea_1 seq 5 deny 192.168.1.0/24
ip prefix-list NoArea_1 seq 10 permit 0.0.0.0/32

Если не хотим принимать что-то из AREA 2, то на R3:

area 1 filter-list prefix NoArea_1 in

ip prefix-list NoArea_1 seq 5 deny 192.168.2.0/24
ip prefix-list NoArea_1 seq 10 permit 0.0.0.0/32

Multicast. PIM Sparse-mode. Конспект.

Для своей работы PIM использует unicast-маршрутизация для избежания петель.

Режим Sparse не передавает multicast трафик до тех пор, пока тебя не попросят об этом. Это отличие от Dense. Dense флудит трафик через все интерфейсы.
Выбирается точка рандеву — Rendevous Point. Это маршрутизатор, на который накладываются определенные функции. Все остальные мультикаст-маршрутизаторы должны знать о точке рандеву. (Либо руками, либо динамически через Auto-RP или BSR)
Continue reading Multicast. PIM Sparse-mode. Конспект.

Пример конфигурации FHRP

First Hop Redundency Protocol позволяет сделать резервирование шлюза по умолчанию между двумя маршрутизаторами.

В данном случае необходимо, чтобы один из роутеров проверял доступность IP 192.122.3.18 и при недоступности его менял своё состояние с Master-а на Slave.

Для этого нам необходимо настроить IP SLA и track, далее настроить нам протолок FHRP (VRRP, HSRP или GLBP) и прикрутить к нему track.

Интерфейс в сторону сервера на Master
interface Ethernet0/1.192
 encapsulation dot1Q 192
 ip address 192.168.0.2 255.255.255.0
 vrrp 1 ip 192.168.0.254
 vrrp 1 priority 200
 vrrp 1 authentication md5 key-string SERVER_VIP
 vrrp 1 track 10 decrement 100 
exit

Настройка IP SLA и трекинга
ip sla 10
 icmp-echo 192.122.3.18
 frequency 10
ip sla schedule 10 life forever start-time now - не забываем его включить!

track 10 ip sla 10 - трекинг.

Continue reading Пример конфигурации FHRP

EIGRP. Выбор Feasible Successor и Load Balance.

В EIGRP есть понятие Successor и Feasible successor. Successor — маршрутизатор с меньшей метрикой до целевой сети. Feasible Successor — резервный маршрутизатор до той же подсети. В данном примере мы возьмем путь от R6 до R9 до сети 155.1.9.0/24. У нас есть два возможный сценария: R6-R1-R3-R7-R9 и R6-R7-R9. Очевидно, что второй вариант короче.

2015-12-15_11-54

Разберём, как именно маршрут попадает в таблицу маршрутизации.
Посмотрим что у нас видно на маршрутизаторах:

Continue reading EIGRP. Выбор Feasible Successor и Load Balance.

BGP Condition Advertise (Advertise-map)

В заметке будет рассмотрена следующая ситуацию: мы отдаем определенные анонсы своему BGP соседу при соблюдении каких-либо условий. Например, как это было в OSPF reliable conditional default routing, где мы анонсировали основной маршрут в зависимости от того, есть ли в таблице маршрутизации нужная информация или нет.

Continue reading BGP Condition Advertise (Advertise-map)

Конфигурирование FCoE на платформе Nexus 5600 и MDS 9124

FCoE Nexus

Здесь будет рассмотрен пример конфигурирования FCoE на оборудовании Nexus 5k и FC-коммутаторе Cisco MDS 9124.

В данной схеме ядром SAN является MDS 9124.

Необходимо включить FCoE на коммутаторе Nexus 5k:

N5K# feature fcoe

Порт в сторону сервера UCS должен быть настроен в режиме trunk. Это необходимо для работы FCoE, т.к. VSAN передается в назначенном FCoE VLAN-е

Continue reading Конфигурирование FCoE на платформе Nexus 5600 и MDS 9124