MPLS L3 VPN

MPLS VPN позволяет оператору связи строить туннели для разных клиентов, объединяя локальные сети клиентов в одну.

При разговоре о MPLS L3 VPN следует сначала упомянуть о технологии VRF.
VRF (Virtual Routing and Forwarding) — технология, позволяющая на одном физическом маршрутизаторе создать несколько логических маршрутизаторов. У каждого из этих маршрутизаторов будет своя RIB и FIB, которая будет независимой от других RIB и FIB на этом устройстве и также независима от глобальной таблицы.

В контексте MPLS VPN маршрутизаторы клиента называются CE (Client Edge), маршрутизаторы провайдера PE (Provider Edge) (те, к которым подключены CE) и P (находятся в облаке MPLS).
MPLS_VRF

Continue reading MPLS L3 VPN

GRE туннели между маршрутизаторами Cisco

Опишем простую настройку GRE-туннеля между двумя маршрутизаторами Cisco.

За основу возьмем INEшную топологию и настроим туннель между двумя маршрутизатора, чтобы не забыть, как это делается. Настройка крайне просто и займет совсем немного времени, просто нужно помнить определенные моменты.

ine_gre

Настраиваем туннель между маршрутизаторами R1 и R10. В итоге мы должны добиться того, чтобы была взаимная доступность сетей 192.168.40.0 и 172.16.0.0.

R1:

interface Tunnel0
 ip address 10.0.1.1 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 169.254.54.2
 
ip route 192.168.40.0 255.255.255.0 Tunnel0

R10:

interface Tunnel0
 ip address 10.0.1.2 255.255.255.0
 tunnel source Ethernet0/0
 tunnel destination 169.254.54.1
 
ip route 172.16.0.0 255.255.255.0 Tunnel0

Как видно, настройка крайне проста и тривиальна. Мы создали туннельный интерфейс, назначили ему ip-адрес, привязали его в внешнему интерфейсу маршрутизатора и указываем маршрут на внутреннюю подсеть соседнего маршрутизатора через наш туннельный интерфейс.